SuccessConsole Output

Started from command line by ynhci
Building in workspace /var/lib/jenkins/jobs/thelounge_ynh PR11 (Rafi59)/workspace
[workspace] $ /bin/sh -xe /tmp/jenkins6357839144548534675.sh
+ /home/CI_package_check/analyseCI.sh /home/yunohost.app/ssh_chroot_directories/Rafi59/data/thelounge_ynh PR11 thelounge_ynh PR11 (Rafi59)

Sat Oct 26 18:30:08 UTC 2019
Wait for work starting...
..........
Sat Oct 26 18:35:08 UTC 2019
Package check currently test the package
Start a test
Loads functions from launcher.sh
Loads functions from testing_process.sh
Loads functions from log_extractor.sh
Restore the previous snapshot.
Working time: 4 seconds.
Disable iptables rules.
Disable the network bridge.
Pick up the package which will be tested.
Initialize network for LXC.
RTNETLINK answers: File exists
ifup: failed to bring up lxc-pchecker
Activate iptables rules.
Parsing of check_process file

Tests serie: Test complet

>> YunoHost versions:
Start the LXC container.
Create witness files...
Working time: 5 seconds.
Working time: 4 seconds.
Debian GNU/Linux 9
yunohost: 
  repo: stable
  version: 3.6.5.2
yunohost-admin: 
  repo: stable
  version: 3.6.5
moulinette: 
  repo: stable
  version: 3.6.4.1
ssowat: 
  repo: stable
  version: 3.6.4
Connection to 10.1.4.2 closed.


>> Package linter... [Test 1/11]

    [YunoHost App Package Linter]

 App packaging documentation - https://yunohost.org/#/packaging_apps
 App package example         - https://github.com/YunoHost/example_ynh
 Official helpers            - https://yunohost.org/#/packaging_apps_helpers_en
 Experimental helpers        - https://github.com/YunoHost-Apps/Experimental_helpers

    Analyzing package /home/CI_package_check/dev_CI/../package_check/thelounge_ynh PR11_check

 [Loading App]


 [Misc File Checks]


 [Sources Management]


 [Manifest]

! Consider adding an 'help' key for argument 'is_public' to explain to the user what it means for *this* app to be public or private :
    "help": {
       "en": "Some explanation"
    } 

 [Install Script]


 [Remove Script]


 [Upgrade Script]


 [Backup Script]


 [Restore Script]

--- SUCCESS ---


>> Installation in a sub path... [Test 2/11]
A LXC container is already running.
Working time: 2 seconds.
Working time: 4 minutes, 52 seconds.
Installation successful. (0)
Info: yunohost.app app_install - [963.1] Installing application thelounge…
Info:  [+...................] > Validating installation parameters... [00h00m,00s]
Info:  [#+..................] > Storing installation settings... [00h00m,02s]
Info:  [##++................] > Configuring firewall... [00h00m,00s]
Info:  [####+...............] > Installing dependencies... [00h00m,09s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [963.1] 
                                                                           0.1%
                                                                           1.1%
##                                                                         3.0%
#####                                                                      7.1%
##########                                                                14.9%
########################                                                  33.6%
####################################                                      50.3%
#############################################                             62.7%
#########################################################                 80.2%
##############################################################            86.5%
##################################################################        92.8%
#######################################################################   99.3%
######################################################################## 100.0%
Info:  [#####++.............] > Setting up source files... [00h00m,04s]
Warning: yunohost.hook <lambda> - [963.1] npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
Info:  [#######+............] > Installing The Lounge... [00h00m,01s]
Warning: yunohost.hook <lambda> - [963.1] npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
Warning: yunohost.hook <lambda> - [963.1] node-pre-gyp WARN Using request for node-pre-gyp https download
Warning: yunohost.hook <lambda> - [963.1] npm notice created a lockfile as package-lock.json. You should commit this file.
Warning: yunohost.hook <lambda> - [963.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Info:  [########++..........] > Configuring nginx web server... [00h04m,23s]
Info:  [##########+.........] > Configuring system user... [00h00m,02s]
Info:  [###########+........] > Configuring a systemd service... [00h00m,04s]
Warning: yunohost.hook <lambda> - [963.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [############++......] > Configuring log rotation... [00h00m,03s]
Info:  [##############+.....] > Starting a systemd service... [00h00m,01s]
Info:  [###############++...] > Configuring SSOwat... [00h00m,00s]
Info:  [#################+..] > Reloading nginx web server... [00h00m,00s]
Info:  [####################] > Installation of thelounge completed [00h00m,01s]

Try to access by url...
Test url: sous.domain.tld/path
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/path/
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Create a snapshot for sub path installation.
Working time: 39 seconds.
Start the LXC container.
Create witness files...
Working time: 5 seconds.
Working time: 4 seconds.

Deleting...
A LXC container is already running.
Working time: 2 seconds.
Working time: 15 seconds.
Deleting successful. (0)
Info: yunohost.app app_remove - [972.1] Removing application thelounge…
Info:  [++..................] > Loading installation settings... [00h00m,00s]
Error: moulinette.core translate - unable to retrieve key 'service_description_thelounge' for default locale 'en'
Info:  [##++................] > Removing thelounge service... [00h00m,02s]
Warning: yunohost.hook <lambda> - [972.1] Removed /etc/systemd/system/default.target.wants/thelounge.service.
Info:  [####++..............] > Stopping and removing the systemd service... [00h00m,00s]
Info:  [######++............] > Removing dependencies... [00h00m,01s]
Info:  /usr/local/n wasn't deleted because it doesn't exist.
Info:  [########++..........] > Removing app main directory... [00h00m,00s]
Info:  [##########++........] > Removing nginx web server configuration... [00h00m,02s]
Info:  [############++......] > Removing logrotate configuration... [00h00m,01s]
Info:  [##############++....] > Closing port 9009...
Info:  [################++..] > Removing the dedicated system user... [00h00m,07s]
Info:  [####################] > Removal of thelounge completed [00h00m,01s]
--- SUCCESS ---

Reinstall the application after a removing.
A LXC container is already running.
Working time: 2 seconds.
Working time: 4 minutes, 45 seconds.
Installation successful. (0)
Info: yunohost.app app_install - [1523.1] Installing application thelounge…
Info:  [+...................] > Validating installation parameters... [00h00m,00s]
Info:  [#+..................] > Storing installation settings... [00h00m,02s]
Info:  [##++................] > Configuring firewall... [00h00m,01s]
Info:  [####+...............] > Installing dependencies... [00h00m,07s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [1523.1] 
                                                                           0.0%
                                                                           0.5%
#                                                                          1.5%
##                                                                         3.6%
#####                                                                      8.3%
##############                                                            19.5%
##########################                                                36.6%
####################################                                      51.0%
##############################################                            64.1%
#######################################################                   76.8%
############################################################              83.3%
################################################################          89.0%
####################################################################      95.5%
######################################################################## 100.0%
Info:  [#####++.............] > Setting up source files... [00h00m,04s]
Warning: yunohost.hook <lambda> - [1523.1] npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
Info:  [#######+............] > Installing The Lounge... [00h00m,07s]
Warning: yunohost.hook <lambda> - [1523.1] npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
Warning: yunohost.hook <lambda> - [1523.1] node-pre-gyp WARN Using request for node-pre-gyp https download
Warning: yunohost.hook <lambda> - [1523.1] npm notice created a lockfile as package-lock.json. You should commit this file.
Warning: yunohost.hook <lambda> - [1523.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1523.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1523.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1523.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1523.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1523.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1523.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1523.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1523.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1523.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1523.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1523.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1523.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1523.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1523.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1523.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1523.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1523.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1523.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1523.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1523.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1523.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1523.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1523.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Info:  [########++..........] > Configuring nginx web server... [00h04m,11s]
Info:  [##########+.........] > Configuring system user... [00h00m,02s]
Info:  [###########+........] > Configuring a systemd service... [00h00m,04s]
Warning: yunohost.hook <lambda> - [1523.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [############++......] > Configuring log rotation... [00h00m,03s]
Info:  [##############+.....] > Starting a systemd service... [00h00m,01s]
Info:  [###############++...] > Configuring SSOwat... [00h00m,00s]
Info:  [#################+..] > Reloading nginx web server... [00h00m,00s]

Try to access by url...
Test url: sous.domain.tld/path
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/path/
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 20 seconds.
Working time for this test: 11 minutes, 13 seconds.


>> Installation on the root... [Test 3/11]
Start the LXC container.Start the LXC container.
Create witness files...
Working time: 5 seconds.
Working time: 4 minutes, 52 seconds.
Installation successful. (0)
Info: yunohost.app app_install - [918.1] Installing application thelounge…
Info:  [+...................] > Validating installation parameters... [00h00m,00s]
Info:  [#+..................] > Storing installation settings... [00h00m,02s]
Info:  [##++................] > Configuring firewall... [00h00m,00s]
Info:  [####+...............] > Installing dependencies... [00h00m,09s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [918.1] 
                                                                           0.8%
#######                                                                   10.2%
#################                                                         24.4%
#############################                                             41.0%
##########################################                                59.1%
########################################################                  78.3%
############################################################              84.6%
#################################################################         90.9%
######################################################################    97.4%
######################################################################## 100.0%
Info:  [#####++.............] > Setting up source files... [00h00m,03s]
Warning: yunohost.hook <lambda> - [918.1] npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
Info:  [#######+............] > Installing The Lounge... [00h00m,02s]
Warning: yunohost.hook <lambda> - [918.1] npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
Warning: yunohost.hook <lambda> - [918.1] node-pre-gyp WARN Using request for node-pre-gyp https download
Warning: yunohost.hook <lambda> - [918.1] npm notice created a lockfile as package-lock.json. You should commit this file.
Warning: yunohost.hook <lambda> - [918.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [918.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [918.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [918.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [918.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [918.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [918.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [918.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [918.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [918.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [918.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [918.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [918.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [918.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [918.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [918.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [918.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [918.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [918.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [918.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [918.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [918.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [918.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [918.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Info:  [########++..........] > Configuring nginx web server... [00h04m,20s]
Info:  [##########+.........] > Configuring system user... [00h00m,02s]
Info:  [###########+........] > Configuring a systemd service... [00h00m,03s]
Warning: yunohost.hook <lambda> - [918.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [############++......] > Configuring log rotation... [00h00m,04s]
Info:  [##############+.....] > Starting a systemd service... [00h00m,00s]
Info:  [###############++...] > Configuring SSOwat... [00h00m,01s]
Info:  [#################+..] > Reloading nginx web server... [00h00m,00s]
Info:  [####################] > Installation of thelounge completed [00h00m,00s]

Try to access by url...
Test url: sous.domain.tld
Real url: http://sous.domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/
Real url: http://sous.domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Create a snapshot for root installation.
Working time: 37 seconds.
Start the LXC container.
Create witness files...
Working time: 10 seconds.
Working time: 1 second.

Deleting...
A LXC container is already running.
Working time: 2 seconds.
Working time: 15 seconds.
Deleting successful. (0)
Info: yunohost.app app_remove - [976.1] Removing application thelounge…
Info:  [++..................] > Loading installation settings... [00h00m,00s]
Error: moulinette.core translate - unable to retrieve key 'service_description_thelounge' for default locale 'en'
Info:  [##++................] > Removing thelounge service... [00h00m,01s]
Warning: yunohost.hook <lambda> - [976.1] Removed /etc/systemd/system/default.target.wants/thelounge.service.
Info:  [####++..............] > Stopping and removing the systemd service... [00h00m,01s]
Info:  [######++............] > Removing dependencies... [00h00m,00s]
Info:  /usr/local/n wasn't deleted because it doesn't exist.
Info:  [########++..........] > Removing app main directory... [00h00m,01s]
Info:  [##########++........] > Removing nginx web server configuration... [00h00m,02s]
Info:  [############++......] > Removing logrotate configuration... [00h00m,00s]
Info:  [##############++....] > Closing port 9009...
Info:  [################++..] > Removing the dedicated system user... [00h00m,06s]
Info:  [####################] > Removal of thelounge completed [00h00m,01s]
--- SUCCESS ---

Reinstall the application after a removing.
A LXC container is already running.
Working time: 2 seconds.
Working time: 4 minutes, 38 seconds.
Installation successful. (0)
Info: yunohost.app app_install - [1543.1] Installing application thelounge…
Info:  [+...................] > Validating installation parameters... [00h00m,00s]
Info:  [#+..................] > Storing installation settings... [00h00m,01s]
Info:  [##++................] > Configuring firewall... [00h00m,01s]
Info:  [####+...............] > Installing dependencies... [00h00m,07s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [1543.1] 
                                                                           0.2%
###                                                                        4.2%
########                                                                  11.2%
#################                                                         24.3%
#############################                                             41.7%
########################################                                  56.5%
#####################################################                     74.9%
##########################################################                80.6%
##############################################################            87.0%
###################################################################       93.2%
#######################################################################   99.7%
######################################################################## 100.0%
Info:  [#####++.............] > Setting up source files... [00h00m,04s]
Warning: yunohost.hook <lambda> - [1543.1] npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
Info:  [#######+............] > Installing The Lounge... [00h00m,02s]
Warning: yunohost.hook <lambda> - [1543.1] npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
Warning: yunohost.hook <lambda> - [1543.1] node-pre-gyp WARN Using request for node-pre-gyp https download
Warning: yunohost.hook <lambda> - [1543.1] npm notice created a lockfile as package-lock.json. You should commit this file.
Warning: yunohost.hook <lambda> - [1543.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1543.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1543.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1543.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1543.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1543.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1543.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1543.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1543.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1543.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1543.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1543.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1543.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1543.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1543.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1543.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1543.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1543.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1543.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1543.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [1543.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1543.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [1543.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [1543.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Info:  [########++..........] > Configuring nginx web server... [00h04m,09s]
Info:  [##########+.........] > Configuring system user... [00h00m,02s]
Info:  [###########+........] > Configuring a systemd service... [00h00m,04s]
Warning: yunohost.hook <lambda> - [1543.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [############++......] > Configuring log rotation... [00h00m,03s]
Info:  [##############+.....] > Starting a systemd service... [00h00m,01s]
Info:  [###############++...] > Configuring SSOwat... [00h00m,00s]
Info:  [#################+..] > Reloading nginx web server... [00h00m,00s]

Try to access by url...
Test url: sous.domain.tld
Real url: http://sous.domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/
Real url: http://sous.domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 19 seconds.
Working time for this test: 11 minutes, 6 seconds.


>> Upgrade from the same version... [Test 4/11]

Preliminary install...
Uses an existing snapshot for sub path installation.
Working time: 28 seconds.

Upgrade...
Start the LXC container.
Create witness files...
Working time: 6 seconds.
Working time: 2 minutes, 50 seconds.
Upgrade successful. (0)
Info: yunohost.app app_upgrade - [938.1] Now upgrading app thelounge…
Info:  [+...................] > Loading installation settings... [00h00m,00s]
Info:  Upgrade forced for package check.
Info:  [#+..................] > Ensuring downward compatibility... [00h00m,02s]
Info:  [##++................] > Backing up the app before upgrading (may take a while)... [00h00m,00s]
Info: yunohost.backup _collect_app_files - [1135.1] Collecting files to be backuped for thelounge…
Info:  [++..................] > Loading installation settings... [00h00m,00s]
Info:  [##++................] > Stopping a systemd service... [00h00m,01s]
Info:  [####++..............] > Backing up the main app directory... [00h00m,00s]
Info:  [######++............] > Backing up nginx web server configuration... [00h00m,01s]
Info:  [########+++.........] > Backing up logrotate configuration... [00h00m,00s]
Info:  [###########++.......] > Backing up systemd configuration... [00h00m,00s]
Info:  [#############++.....] > Backing up config path... [00h00m,01s]
Info:  [###############++...] > Starting a systemd service... [00h00m,00s]
Info: yunohost.backup backup_create - [1135.1] Now creating a backup archive from the files collected…
Info:  [####+...............] > Stopping a systemd service... [00h01m,05s]
Info:  [#####++.............] > Upgrading source files... [00h00m,00s]
Info:  [#######+............] > Upgrading dependencies... [00h00m,02s]
Warning: yunohost.hook <lambda> - [938.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [938.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [938.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [938.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [938.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [938.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Info:  [########++..........] > Upgrading nginx web server configuration... [00h01m,30s]
Info:  [##########+.........] > Making sure dedicated system user exists... [00h00m,01s]
Info:  [###########+........] > Making sure dedicated system user exists... [00h00m,02s]
Info:  [############++......] > Upgrading logrotate configuration... [00h00m,01s]
Info:  [##############+.....] > Upgrading SSOwat configuration... [00h00m,01s]
Info:  [###############++...] > Starting a systemd service... [00h00m,00s]
Info:  [#################+..] > Reloading nginx web server... [00h00m,01s]

Try to access by url...
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/path/
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---

Deleting...
A LXC container is already running.
Working time: 2 seconds.
Working time: 16 seconds.
Deleting successful. (0)
Stop the LXC container
Restore the previous snapshot.
Working time: 16 seconds.


>> Upgrade from the commit 7a4ce3de66d44b45ea08e8feb07b925a821ec760... [Test 5/11]

Preliminary install...
Start the LXC container.
Create witness files...
Working time: 5 seconds.
Working time: 4 minutes, 46 seconds.
Installation successful. (0)
Warning: yunohost.service _run_service_command - [186.1] Unable to execute command 'systemctl reload fail2ban'
Info: yunohost.app app_install - [923.1] Installing application thelounge…
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [923.1] 
                                                                           0.1%
                                                                           0.4%
                                                                           1.0%
#                                                                          2.2%
###                                                                        5.1%
########                                                                  11.6%
##################                                                        25.2%
############################                                              39.0%
##################################                                        48.5%
################################################                          67.6%
########################################################                  79.1%
#############################################################             85.3%
##################################################################        91.9%
######################################################################    97.6%
######################################################################## 100.0%
Warning: yunohost.hook <lambda> - [923.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Warning: yunohost.hook <lambda> - [923.1] npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
Warning: yunohost.hook <lambda> - [923.1] npm WARN deprecated hawk@6.0.2: This module moved to @hapi/hawk. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
Warning: yunohost.hook <lambda> - [923.1] npm WARN deprecated hoek@4.2.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
Warning: yunohost.hook <lambda> - [923.1] npm WARN deprecated cryptiles@3.1.4: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
Warning: yunohost.hook <lambda> - [923.1] npm WARN deprecated boom@4.3.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
Warning: yunohost.hook <lambda> - [923.1] npm WARN deprecated sntp@2.1.0: This module moved to @hapi/sntp. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
Warning: yunohost.hook <lambda> - [923.1] npm WARN deprecated uws@9.14.0: New code is available at github.com/uNetworking/uWebSockets.js
Warning: yunohost.hook <lambda> - [923.1] npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
Warning: yunohost.hook <lambda> - [923.1] npm WARN deprecated boom@5.2.0: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
Warning: yunohost.hook <lambda> - [923.1] npm notice created a lockfile as package-lock.json. You should commit this file.
Warning: yunohost.hook <lambda> - [923.1] npm WARN ajv-keywords@3.4.1 requires a peer of ajv@^6.9.1 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [923.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [923.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [923.1] npm WARN ajv-keywords@3.4.1 requires a peer of ajv@^6.9.1 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [923.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [923.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [923.1] npm WARN ajv-keywords@3.4.1 requires a peer of ajv@^6.9.1 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [923.1] npm WARN webpack-cli@3.3.9 requires a peer of webpack@4.x.x but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [923.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [923.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [923.1] npm WARN ajv-keywords@3.4.1 requires a peer of ajv@^6.9.1 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [923.1] npm WARN webpack-cli@3.3.9 requires a peer of webpack@4.x.x but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [923.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [923.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

Upgrade...
A LXC container is already running.
Working time: 4 seconds.
Working time: 3 minutes, 15 seconds.
Upgrade successful. (0)
Info: yunohost.app app_upgrade - [2927.1] Now upgrading app thelounge…
Info:  [+...................] > Loading installation settings... [00h00m,00s]
Info:  [#+..................] > Ensuring downward compatibility... [00h00m,01s]
Warning: yunohost.hook <lambda> - [2927.1] [WARN] This app doesn't have any backup script.
Info:  [##++................] > Backing up the app before upgrading (may take a while)... [00h00m,01s]
Info:  [####+...............] > Stopping a systemd service... [00h00m,00s]
Info:  [#####++.............] > Upgrading source files... [00h00m,00s]
Info:  [#######+............] > Upgrading dependencies... [00h00m,01s]
Warning: yunohost.hook <lambda> - [2927.1] npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
Warning: yunohost.hook <lambda> - [2927.1] npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
Warning: yunohost.hook <lambda> - [2927.1] npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
Warning: yunohost.hook <lambda> - [2927.1] node-pre-gyp WARN Using needle for node-pre-gyp https download
Warning: yunohost.hook <lambda> - [2927.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [2927.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [2927.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [2927.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [2927.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [2927.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Info:  [########++..........] > Upgrading nginx web server configuration... [00h03m,02s]
Info:  [##########+.........] > Making sure dedicated system user exists... [00h00m,02s]
Info:  [###########+........] > Making sure dedicated system user exists... [00h00m,01s]
Info:  [############++......] > Upgrading logrotate configuration... [00h00m,01s]
Info:  [##############+.....] > Upgrading SSOwat configuration... [00h00m,01s]
Info:  [###############++...] > Starting a systemd service... [00h00m,01s]
Info:  [#################+..] > Reloading nginx web server... [00h00m,00s]

Try to access by url...
Test url: sous.domain.tld/path
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/path/
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---

Deleting...
A LXC container is already running.
Working time: 2 seconds.
Working time: 16 seconds.
Deleting successful. (0)
Stop the LXC container
Restore the previous snapshot.
Working time: 19 seconds.
Restore the previous snapshot.
Working time: 4 seconds.
Working time for this test: 12 minutes, 55 seconds.


>> Installation in private mode... [Test 6/11]
Start the LXC container.Start the LXC container.
Create witness files...
Working time: 10 seconds.
Working time: 4 minutes, 51 seconds.
Installation successful. (0)
Info: yunohost.app app_install - [906.1] Installing application thelounge…
Info:  [+...................] > Validating installation parameters... [00h00m,00s]
Info:  [#+..................] > Storing installation settings... [00h00m,01s]
Info:  [##++................] > Configuring firewall... [00h00m,01s]
Info:  [####+...............] > Installing dependencies... [00h00m,06s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [906.1] 
                                                                           0.2%
                                                                           1.2%
##                                                                         3.3%
#####                                                                      8.0%
############                                                              16.7%
####################                                                      28.8%
################################                                          45.4%
####################################                                      50.3%
####################################                                      50.4%
####################################                                      50.8%
#####################################                                     51.5%
#######################################                                   54.2%
##########################################                                58.4%
################################################                          67.1%
#########################################################                 79.6%
#################################################################         90.6%
#####################################################################     96.6%
######################################################################## 100.0%
Info:  [#####++.............] > Setting up source files... [00h00m,06s]
Warning:Warning: yunohost.hook <lambda> - [906.1] npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
Info:  [#######+............] > Installing The Lounge... [00h00m,02s]
Warning: yunohost.hook <lambda> - [906.1] npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
Warning: yunohost.hook <lambda> - [906.1] node-pre-gyp WARN Using request for node-pre-gyp https download
Warning: yunohost.hook <lambda> - [906.1] npm notice created a lockfile as package-lock.json. You should commit this file.
Warning: yunohost.hook <lambda> - [906.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [906.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [906.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [906.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [906.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [906.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [906.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [906.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [906.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [906.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [906.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [906.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [906.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [906.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [906.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [906.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [906.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [906.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [906.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [906.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [906.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [906.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [906.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [906.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Info:  [########++..........] > Configuring nginx web server... [00h04m,22s]
Info:  [##########+.........] > Configuring system user... [00h00m,02s]
Info:  [###########+........] > Configuring a systemd service... [00h00m,03s]
Warning: yunohost.hook <lambda> - [906.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [############++......] > Configuring log rotation... [00h00m,04s]
Info:  [##############+.....] > Starting a systemd service... [00h00m,00s]
Info:  [###############++...] > Configuring SSOwat... [00h00m,01s]
Info:  [#################+..] > Reloading nginx web server... [00h00m,00s]
Info:  [####################] > Installation of thelounge completed [00h00m,00s]

Try to access by url...
Test url: sous.domain.tld
Real url: https://domain.tld/yunohost/sso/?r=aHR0cHM6Ly9zb3VzLmRvbWFpbi50bGQv
HTTP code: 200
Title of the page: YunoHost Portal
The connection attempt fall on the YunoHost portal.
Test url: sous.domain.tld/
Real url: https://domain.tld/yunohost/sso/?r=aHR0cHM6Ly9zb3VzLmRvbWFpbi50bGQv
HTTP code: 200
Title of the page: YunoHost Portal
The connection attempt fall on the YunoHost portal.
--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 16 seconds.
Start the LXC container.Start the LXC container.
Create witness files...
Working time: 10 seconds.
Working time: 4 minutes, 46 seconds.
Installation successful. (0)
Info: yunohost.app app_install - [910.1] Installing application thelounge…
Info:  [+...................] > Validating installation parameters... [00h00m,00s]
Info:  [#+..................] > Storing installation settings... [00h00m,01s]
Info:  [##++................] > Configuring firewall... [00h00m,01s]
Info:  [####+...............] > Installing dependencies... [00h00m,07s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [910.1] 
                                                                           0.1%
                                                                           0.5%
#                                                                          1.5%
##                                                                         3.5%
#####                                                                      7.9%
############                                                              17.9%
#######################                                                   32.8%
###################################                                       49.2%
############################################                              61.7%
#########################################################                 79.6%
#############################################################             85.6%
#################################################################         91.5%
######################################################################    97.3%
######################################################################## 100.0%
Info:  [#####++.............] > Setting up source files... [00h00m,04s]
Info:  [#######+............] > Installing The Lounge... [00h00m,02s]
Warning: yunohost.hook <lambda> - [910.1] npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
Warning: yunohost.hook <lambda> - [910.1] npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
Warning: yunohost.hook <lambda> - [910.1] node-pre-gyp WARN Using request for node-pre-gyp https download
Warning: yunohost.hook <lambda> - [910.1] npm notice created a lockfile as package-lock.json. You should commit this file.
Warning: yunohost.hook <lambda> - [910.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Info:  [########++..........] > Configuring nginx web server... [00h04m,17s]
Info:  [##########+.........] > Configuring system user... [00h00m,02s]
Info:  [###########+........] > Configuring a systemd service... [00h00m,04s]
Warning: yunohost.hook <lambda> - [910.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [############++......] > Configuring log rotation... [00h00m,03s]
Info:  [##############+.....] > Starting a systemd service... [00h00m,01s]
Info:  [###############++...] > Configuring SSOwat... [00h00m,00s]
Info:  [#################+..] > Reloading nginx web server... [00h00m,00s]

Try to access by url...
Test url: sous.domain.tld/path
Real url: https://domain.tld/yunohost/sso/?r=aHR0cHM6Ly9zb3VzLmRvbWFpbi50bGQvcGF0aC8=
HTTP code: 200
Title of the page: YunoHost Portal
The connection attempt fall on the YunoHost portal.
Test url: sous.domain.tld/path/
Real url: https://domain.tld/yunohost/sso/?r=aHR0cHM6Ly9zb3VzLmRvbWFpbi50bGQvcGF0aC8=
HTTP code: 200
Title of the page: YunoHost Portal
The connection attempt fall on the YunoHost portal.
--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 17 seconds.
Restore the previous snapshot.
Working time: 4 seconds.
Working time for this test: 10 minutes, 39 seconds.


>> Installation in public mode... [Test 7/11]
Start the LXC container.
Create witness files...
Working time: 7 seconds.
Working time: 4 minutes, 48 seconds.
Installation successful. (0)
Info: yunohost.app app_install - [913.1] Installing application thelounge…
Info:  [+...................] > Validating installation parameters... [00h00m,00s]
Info:  [#+..................] > Storing installation settings... [00h00m,01s]
Info:  [##++................] > Configuring firewall... [00h00m,01s]
Info:  [####+...............] > Installing dependencies... [00h00m,09s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [913.1] 
#                                                                          2.7%
###############                                                           21.8%
###########################                                               38.7%
#########################################                                 57.1%
###################################################                       71.0%
#######################################################                   77.0%
################################################################          89.8%
#####################################################################     96.2%
######################################################################## 100.0%
Info:  [#####++.............] > Setting up source files... [00h00m,03s]
Info:  [#######+............] > Installing The Lounge... [00h00m,02s]
Warning: yunohost.hook <lambda> - [913.1] npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
Warning: yunohost.hook <lambda> - [913.1] npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
Warning: yunohost.hook <lambda> - [913.1] node-pre-gyp WARN Using request for node-pre-gyp https download
Warning: yunohost.hook <lambda> - [913.1] npm notice created a lockfile as package-lock.json. You should commit this file.
Warning: yunohost.hook <lambda> - [913.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [913.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [913.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [913.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [913.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [913.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [913.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [913.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [913.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [913.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [913.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [913.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [913.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [913.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [913.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [913.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [913.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [913.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [913.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [913.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [913.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [913.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [913.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [913.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Info:  [########++..........] > Configuring nginx web server... [00h04m,18s]
Info:  [##########+.........] > Configuring system user... [00h00m,01s]
Info:  [###########+........] > Configuring a systemd service... [00h00m,04s]
Warning: yunohost.hook <lambda> - [913.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [############++......] > Configuring log rotation... [00h00m,03s]
Info:  [##############+.....] > Starting a systemd service... [00h00m,01s]
Info:  [###############++...] > Configuring SSOwat... [00h00m,00s]
Info:  [#################+..] > Reloading nginx web server... [00h00m,01s]

Try to access by url...
Test url: sous.domain.tld
Real url: http://sous.domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/
Real url: http://sous.domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 20 seconds.
Start the LXC container.
Create witness files...
Working time: 9 seconds.
Working time: 4 minutes, 48 seconds.
Installation successful. (0)
Info: yunohost.app app_install - [898.1] Installing application thelounge…
Info:  [+...................] > Validating installation parameters... [00h00m,00s]
Info:  [#+..................] > Storing installation settings... [00h00m,01s]
Info:  [##++................] > Configuring firewall... [00h00m,01s]
Info:  [####+...............] > Installing dependencies... [00h00m,07s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [898.1] 
                                                                           0.1%
##########                                                                15.2%
#########################                                                 35.3%
###################################                                       49.8%
##############################################                            64.5%
#########################################################                 79.2%
#############################################################             85.6%
##################################################################        92.0%
######################################################################    98.4%
######################################################################## 100.0%
Info:  [#####++.............] > Setting up source files... [00h00m,03s]
Warning: yunohost.hook <lambda> - [898.1] npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
Info:  [#######+............] > Installing The Lounge... [00h00m,02s]
Warning: yunohost.hook <lambda> - [898.1] npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
Warning: yunohost.hook <lambda> - [898.1] node-pre-gyp WARN Using request for node-pre-gyp https download
Warning: yunohost.hook <lambda> - [898.1] npm notice created a lockfile as package-lock.json. You should commit this file.
Warning: yunohost.hook <lambda> - [898.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [898.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [898.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [898.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [898.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [898.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [898.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [898.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [898.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [898.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [898.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [898.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [898.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [898.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [898.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [898.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [898.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [898.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [898.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [898.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [898.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [898.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [898.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [898.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Info:  [########++..........] > Configuring nginx web server... [00h04m,20s]
Info:  [##########+.........] > Configuring system user... [00h00m,01s]
Info:  [###########+........] > Configuring a systemd service... [00h00m,04s]
Warning: yunohost.hook <lambda> - [898.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [############++......] > Configuring log rotation... [00h00m,03s]
Info:  [##############+.....] > Starting a systemd service... [00h00m,01s]
Info:  [###############++...] > Configuring SSOwat... [00h00m,00s]
Info:  [#################+..] > Reloading nginx web server... [00h00m,00s]

Try to access by url...
Test url: sous.domain.tld/path
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/path/
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 17 seconds.
Restore the previous snapshot.
Working time: 5 seconds.
Working time for this test: 10 minutes, 39 seconds.


>> Malformed path... [Test 8/11]
Start the LXC container.
Create witness files...
Working time: 10 seconds.
Working time: 4 minutes, 46 seconds.
Installation successful. (0)
Info: yunohost.app app_install - [910.1] Installing application thelounge…
Info:  [+...................] > Validating installation parameters... [00h00m,00s]
Info:  [#+..................] > Storing installation settings... [00h00m,02s]
Info:  [##++................] > Configuring firewall... [00h00m,00s]
Info:  [####+...............] > Installing dependencies... [00h00m,08s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [910.1] 
                                                                           0.1%
#                                                                          2.6%
#####                                                                      7.3%
##############                                                            20.6%
###########################                                               38.6%
######################################                                    53.1%
###################################################                       71.0%
#######################################################                   77.3%
############################################################              83.7%
################################################################          90.1%
#####################################################################     96.4%
######################################################################## 100.0%
Info:  [#####++.............] > Setting up source files... [00h00m,04s]
Warning: yunohost.hook <lambda> - [910.1] npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
Info:  [#######+............] > Installing The Lounge... [00h00m,02s]
Warning: yunohost.hook <lambda> - [910.1] npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
Warning: yunohost.hook <lambda> - [910.1] node-pre-gyp WARN Using request for node-pre-gyp https download
Warning: yunohost.hook <lambda> - [910.1] npm notice created a lockfile as package-lock.json. You should commit this file.
Warning: yunohost.hook <lambda> - [910.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [910.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [910.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Info:  [########++..........] > Configuring nginx web server... [00h04m,18s]
Info:  [##########+.........] > Configuring system user... [00h00m,01s]
Info:  [###########+........] > Configuring a systemd service... [00h00m,04s]
Warning: yunohost.hook <lambda> - [910.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [############++......] > Configuring log rotation... [00h00m,03s]
Info:  [##############+.....] > Starting a systemd service... [00h00m,01s]
Info:  [###############++...] > Configuring SSOwat... [00h00m,00s]
Info:  [#################+..] > Reloading nginx web server... [00h00m,00s]

Try to access by url...
Test url: sous.domain.tld/path
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/path/
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 17 seconds.
Working time for this test: 5 minutes, 15 seconds.


>> Port already used... [Test 9/11]
Start the LXC container.Start the LXC container.
Create witness files...
Working time: 9 seconds.
Working time: 1 second.
A LXC container is already running.
Working time: 2 seconds.
Working time: 4 minutes, 46 seconds.
Installation successful. (0)
Info: yunohost.app app_install - [963.1] Installing application thelounge…
Info:  [+...................] > Validating installation parameters... [00h00m,00s]
Info:  [#+..................] > Storing installation settings... [00h00m,01s]
Info:  [##++................] > Configuring firewall... [00h00m,01s]
Info:  [####+...............] > Installing dependencies... [00h00m,08s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [963.1] 
                                                                           0.0%
####                                                                       6.2%
############                                                              16.7%
######################                                                    31.3%
###################################                                       49.6%
#############################################                             63.7%
########################################################                  77.9%
#################################################################         90.6%
#####################################################################     97.0%
######################################################################## 100.0%
Info:  [#####++.............] > Setting up source files... [00h00m,04s]
Info:  [#######+............] > Installing The Lounge... [00h00m,01s]
Warning: yunohost.hook <lambda> - [963.1] npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
Warning: yunohost.hook <lambda> - [963.1] npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
Warning: yunohost.hook <lambda> - [963.1] node-pre-gyp WARN Using request for node-pre-gyp https download
Warning: yunohost.hook <lambda> - [963.1] npm notice created a lockfile as package-lock.json. You should commit this file.
Warning: yunohost.hook <lambda> - [963.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN eslint-plugin-vue@5.2.3 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN vue-eslint-parser@5.0.0 requires a peer of eslint@^5.0.0 but none is installed. You must install peer dependencies yourself.
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.1 (node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Warning: yunohost.hook <lambda> - [963.1] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/watchpack/node_modules/fsevents):
Warning: yunohost.hook <lambda> - [963.1] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
Info:  [########++..........] > Configuring nginx web server... [00h04m,18s]
Info:  [##########+.........] > Configuring system user... [00h00m,01s]
Info:  [###########+........] > Configuring a systemd service... [00h00m,04s]
Warning: yunohost.hook <lambda> - [963.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [############++......] > Configuring log rotation... [00h00m,03s]
Info:  [##############+.....] > Starting a systemd service... [00h00m,01s]
Info:  [###############++...] > Configuring SSOwat... [00h00m,00s]
Info:  [#################+..] > Reloading nginx web server... [00h00m,01s]

Try to access by url...
Test url: sous.domain.tld/path
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/path/
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 18 seconds.
Working time for this test: 5 minutes, 20 seconds.


>> Backup/Restore... [Test 10/11]

Preliminary installation on the root...
Uses an existing snapshot for root installation.
Working time: 30 seconds.

Backup of the application...
Start the LXC container.Start the LXC container..
Create witness files...
Working time: 10 seconds.
Working time: 1 minute, 4 seconds.
Backup successful. (0)
Info: yunohost.backup _collect_app_files - [926.1] Collecting files to be backuped for thelounge…
Info:  [++..................] > Loading installation settings... [00h00m,00s]
Info:  [##++................] > Stopping a systemd service... [00h00m,01s]
Info:  [####++..............] > Backing up the main app directory... [00h00m,00s]
Info:  [######++............] > Backing up nginx web server configuration... [00h00m,00s]
Info:  [########+++.........] > Backing up logrotate configuration... [00h00m,00s]
Info:  [###########++.......] > Backing up systemd configuration... [00h00m,01s]
Info:  [#############++.....] > Backing up config path... [00h00m,00s]
Info:  [###############++...] > Starting a systemd service... [00h00m,00s]
Info: yunohost.backup backup_create - [926.1] Now creating a backup archive from the files collected…
--- SUCCESS ---

Deleting...
A LXC container is already running.
Working time: 2 seconds.
Working time: 16 seconds.
Deleting successful. (0)

Restore after removing the application...
A LXC container is already running.
Working time: 1 second.
Working time: 53 seconds.
Restore successful. (0)
Info: yunohost.backup backup_restore - [1969.1] Preparing archive for restoration…
Info: yunohost.backup _restore_app - [1969.1] Restoring application thelounge…
Info:  [++..................] > Loading settings... [00h00m,00s]
Info:  [##++................] > Validating restoration parameters... [00h00m,01s]
Info:  [####++..............] > Restoring the app main directory... [00h00m,01s]
Info:  [######++............] > Recreating the dedicated system user... [00h00m,00s]
Info:  [########++..........] > Reinstalling dependencies... [00h00m,04s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [1969.1] 
                                                                           0.1%
                                                                           0.8%
#                                                                          2.0%
###                                                                        4.9%
########                                                                  11.5%
##################                                                        25.2%
###########################                                               38.6%
######################################                                    52.9%
###############################################                           66.1%
########################################################                  78.2%
#################################################################         90.6%
#####################################################################     96.7%
######################################################################## 100.0%
Warning: yunohost.hook <lambda> - [1969.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [##########++........] > Restoring the config path... [00h00m,04s]
Info:  [############++......] > Restoring the systemd configuration... [00h00m,00s]
Info:  [##############++....] > Starting a systemd service... [00h00m,01s]
Info:  [################++..] > Reloading nginx web server... [00h00m,01s]

Try to access by url...
Test url: sous.domain.tld
Real url: http://sous.domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/
Real url: http://sous.domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 21 seconds.
Restore the previous snapshot.
Working time: 9 seconds.

Restore on a clean YunoHost system...
Start the LXC container.
Create witness files...
Working time: 10 seconds.
Working time: 51 seconds.
Restore successful. (0)
Info: yunohost.backup backup_restore - [917.1] Preparing archive for restoration…
Info: yunohost.backup _restore_app - [917.1] Restoring application thelounge…
Info:  [++..................] > Loading settings... [00h00m,00s]
Info:  [##++................] > Validating restoration parameters... [00h00m,01s]
Info:  [####++..............] > Restoring the app main directory... [00h00m,01s]
Info:  [######++............] > Recreating the dedicated system user... [00h00m,00s]
Info:  [########++..........] > Reinstalling dependencies... [00h00m,03s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [917.1] 
######                                                                     9.0%
################                                                          23.5%
###########################                                               37.9%
######################################                                    53.5%
###############################################                           65.7%
###################################################                       72.0%
#######################################################                   77.5%
#################################################################         90.3%
#####################################################################     96.7%
######################################################################## 100.0%
Warning: yunohost.hook <lambda> - [917.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [##########++........] > Restoring the config path... [00h00m,05s]
Info:  [############++......] > Restoring the systemd configuration... [00h00m,00s]
Info:  [##############++....] > Starting a systemd service... [00h00m,00s]
Info:  [################++..] > Reloading nginx web server... [00h00m,02s]

Try to access by url...
Test url: sous.domain.tld
Real url: http://sous.domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/
Real url: http://sous.domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 13 seconds.

Preliminary installation in a sub path...
Uses an existing snapshot for sub path installation.
Working time: 29 seconds.

Backup of the application...
Start the LXC container.
Create witness files...
Working time: 12 seconds.
Working time: 1 minute, 5 seconds.
Backup successful. (0)
Info: yunohost.backup _collect_app_files - [937.1] Collecting files to be backuped for thelounge…
Info:  [++..................] > Loading installation settings... [00h00m,00s]
Info:  [##++................] > Stopping a systemd service... [00h00m,00s]
Info:  [####++..............] > Backing up the main app directory... [00h00m,01s]
Info:  [######++............] > Backing up nginx web server configuration... [00h00m,00s]
Info:  [########+++.........] > Backing up logrotate configuration... [00h00m,00s]
Info:  [###########++.......] > Backing up systemd configuration... [00h00m,01s]
Info:  [#############++.....] > Backing up config path... [00h00m,00s]
Info:  [###############++...] > Starting a systemd service... [00h00m,00s]
Info: yunohost.backup backup_create - [937.1] Now creating a backup archive from the files collected…
--- SUCCESS ---

Deleting...
A LXC container is already running.A LXC container is already running.
Working time: 2 seconds.
Working time: 17 seconds.
Deleting successful. (0)

Restore after removing the application...
A LXC container is already running.
Working time: 1 second.
Working time: 52 seconds.
Restore successful. (0)
Info: yunohost.backup backup_restore - [1980.1] Preparing archive for restoration…
Info: yunohost.backup _restore_app - [1980.1] Restoring application thelounge…
Info:  [++..................] > Loading settings... [00h00m,00s]
Info:  [##++................] > Validating restoration parameters... [00h00m,01s]
Info:  [####++..............] > Restoring the app main directory... [00h00m,01s]
Info:  [######++............] > Recreating the dedicated system user... [00h00m,00s]
Info:  [########++..........] > Reinstalling dependencies... [00h00m,04s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [1980.1] 
                                                                           0.0%
                                                                           0.4%
                                                                           1.2%
##                                                                         2.9%
####                                                                       6.9%
###########                                                               15.7%
#####################                                                     30.1%
###############################                                           44.0%
########################################                                  56.7%
##################################################                        69.5%
##########################################################                81.0%
###############################################################           87.5%
###################################################################       93.9%
######################################################################## 100.0%
Warning: yunohost.hook <lambda> - [1980.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [##########++........] > Restoring the config path... [00h00m,05s]
Info:  [############++......] > Restoring the systemd configuration... [00h00m,00s]
Info:  [##############++....] > Starting a systemd service... [00h00m,01s]
Info:  [################++..] > Reloading nginx web server... [00h00m,01s]

Try to access by url...
Test url: sous.domain.tld/path
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/path/
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 20 seconds.
Restore the previous snapshot.
Working time: 9 seconds.

Restore on a clean YunoHost system...
Start the LXC container.
Create witness files...
Working time: 10 seconds.
Working time: 56 seconds.
Restore successful. (0)
Info: yunohost.backup backup_restore - [894.1] Preparing archive for restoration…
Info: yunohost.backup _restore_app - [894.1] Restoring application thelounge…
Info:  [++..................] > Loading settings... [00h00m,00s]
Info:  [##++................] > Validating restoration parameters... [00h00m,01s]
Info:  [####++..............] > Restoring the app main directory... [00h00m,01s]
Info:  [######++............] > Recreating the dedicated system user... [00h00m,00s]
Info:  [########++..........] > Reinstalling dependencies... [00h00m,04s]
Info:  Installation of N - Node.js version management
Warning: yunohost.hook <lambda> - [894.1] 
                                                                           0.0%
                                                                           0.1%
                                                                           0.1%
                                                                           0.2%
                                                                           0.3%
                                                                           0.4%
                                                                           0.5%
                                                                           0.6%
                                                                           0.7%
                                                                           0.8%
                                                                           1.0%
                                                                           1.1%
                                                                           1.3%
#                                                                          1.5%
#                                                                          1.8%
#                                                                          2.1%
#                                                                          2.4%
##                                                                         2.8%
##                                                                         3.2%
##                                                                         3.8%
###                                                                        4.4%
###                                                                        5.1%
####                                                                       5.9%
####                                                                       6.9%
#####                                                                      8.1%
######                                                                     9.5%
#######                                                                   10.8%
########                                                                  12.3%
#########                                                                 13.7%
##########                                                                15.1%
###########                                                               16.5%
#############                                                             18.1%
##############                                                            20.0%
################                                                          22.2%
#################                                                         25.0%
####################                                                      28.2%
##########################                                                37.0%
##############################                                            42.6%
###################################                                       49.1%
#########################################                                 56.9%
###############################################                           65.9%
#########################################################                 79.4%
#############################################################             85.5%
##################################################################        91.8%
######################################################################    97.6%
######################################################################## 100.0%
Info:  [##########++........] > Restoring the config path... [00h00m,08s]
Warning: yunohost.hook <lambda> - [894.1] Created symlink /etc/systemd/system/default.target.wants/thelounge.service → /etc/systemd/system/thelounge.service.
Info:  [############++......] > Restoring the systemd configuration... [00h00m,00s]
Info:  [##############++....] > Starting a systemd service... [00h00m,01s]
Info:  [################++..] > Reloading nginx web server... [00h00m,02s]
Info:  [####################] > Restoration completed for thelounge [00h00m,00s]

Try to access by url...
Test url: sous.domain.tld/path
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/path/
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 15 seconds.
Restore the previous snapshot.
Working time: 5 seconds.
Working time for this test: 9 minutes, 45 seconds.


>> Change URL... [Test 11/11]

Preliminary install...
Uses an existing snapshot for root installation.
Working time: 28 seconds.
Change the url from sous.domain.tld/ to sous.domain.tld/path...
Start the LXC container.
Create witness files...
Working time: 5 seconds.
Working time: 8 seconds.
Change_url script successful. (0)
Warning: yunohost.service _run_service_command - [180.1] Unable to execute command 'systemctl reload fail2ban'
Info:  [+++.................] > Loading installation settings... [00h00m,00s]
Info:  [###+++..............] > Stopping a systemd service... [00h00m,01s]
Info:  [######++++..........] > Updating nginx web server configuration... [00h00m,00s]
Info:  [##########+++.......] > Starting a systemd service... [00h00m,02s]
Info:  [#############+++....] > Reloading nginx web server... [00h00m,00s]

Try to access by url...
Test url: sous.domain.tld/path
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/path/
Real url: http://sous.domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 16 seconds.

Preliminary install...
Uses an existing snapshot for sub path installation.
Working time: 26 seconds.
Change the url from sous.domain.tld/path to sous.domain.tld/path_2...
Start the LXC container.
Create witness files...
Working time: 10 seconds.
Working time: 4 seconds.
Change_url script successful. (0)
Info:  [+++.................] > Loading installation settings... [00h00m,00s]
Info:  [###+++..............] > Stopping a systemd service... [00h00m,01s]
Info:  [######++++..........] > Updating nginx web server configuration... [00h00m,00s]
Info:  [##########+++.......] > Starting a systemd service... [00h00m,02s]
Info:  [#############+++....] > Reloading nginx web server... [00h00m,00s]

Try to access by url...
Test url: sous.domain.tld/path_2
Real url: http://sous.domain.tld/path_2/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/path_2/
Real url: http://sous.domain.tld/path_2/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 15 seconds.

Preliminary install...
Uses an existing snapshot for sub path installation.
Working time: 25 seconds.
Change the url from sous.domain.tld/path to sous.domain.tld/...
Start the LXC container..
Create witness files...
Working time: 11 seconds.
Working time: 4 seconds.
Change_url script successful. (0)
Info:  [+++.................] > Loading installation settings... [00h00m,00s]
Info:  [###+++..............] > Stopping a systemd service... [00h00m,01s]
Info:  [######++++..........] > Updating nginx web server configuration... [00h00m,00s]
Info:  [##########+++.......] > Starting a systemd service... [00h00m,02s]
Info:  [#############+++....] > Reloading nginx web server... [00h00m,00s]

Try to access by url...
Test url: sous.domain.tld
Real url: http://sous.domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: sous.domain.tld/
Real url: http://sous.domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 16 seconds.

Preliminary install...
Uses an existing snapshot for root installation.
Working time: 26 seconds.
Change the url from sous.domain.tld/ to domain.tld/path...
Start the LXC container.
Create witness files...
Working time: 10 seconds.
Working time: 5 seconds.
Change_url script successful. (0)
Info:  [+++.................] > Loading installation settings... [00h00m,00s]
Info:  [###+++..............] > Stopping a systemd service... [00h00m,01s]
Info:  [######++++..........] > Updating nginx web server configuration... [00h00m,00s]
Info:  [##########+++.......] > Starting a systemd service... [00h00m,02s]
Info:  [#############+++....] > Reloading nginx web server... [00h00m,00s]

Try to access by url...
Test url: domain.tld/path
Real url: http://domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: domain.tld/path/
Real url: http://domain.tld/path/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 18 seconds.

Preliminary install...
Uses an existing snapshot for sub path installation.
Working time: 26 seconds.
Change the url from sous.domain.tld/path to domain.tld/path_2...
Start the LXC container..
Create witness files...
Working time: 10 seconds.
Working time: 6 seconds.
Change_url script successful. (0)
Info:  [+++.................] > Loading installation settings... [00h00m,00s]
Info:  [###+++..............] > Stopping a systemd service... [00h00m,00s]
Info:  [######++++..........] > Updating nginx web server configuration... [00h00m,00s]
Info:  [##########+++.......] > Starting a systemd service... [00h00m,03s]
Info:  [#############+++....] > Reloading nginx web server... [00h00m,00s]
Info:  [####################] > Change of URL completed for thelounge [00h00m,00s]

Try to access by url...
Test url: domain.tld/path_2
Real url: http://domain.tld/path_2/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: domain.tld/path_2/
Real url: http://domain.tld/path_2/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 15 seconds.

Preliminary install...
Uses an existing snapshot for sub path installation.
Working time: 26 seconds.
Change the url from sous.domain.tld/path to domain.tld/...
Start the LXC container.Start the LXC container.
Create witness files...
Working time: 10 seconds.
Working time: 6 seconds.
Change_url script successful. (0)
Info:  [+++.................] > Loading installation settings... [00h00m,00s]
Info:  [###+++..............] > Stopping a systemd service... [00h00m,00s]
Info:  [######++++..........] > Updating nginx web server configuration... [00h00m,00s]
Info:  [##########+++.......] > Starting a systemd service... [00h00m,03s]
Info:  [#############+++....] > Reloading nginx web server... [00h00m,00s]

Try to access by url...
Test url: domain.tld
Real url: http://domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


Test url: domain.tld/
Real url: http://domain.tld/
HTTP code: 200
Title of the page: The Lounge
Extract of the page:
   The Lounge The Lounge

   [1]Your JavaScript must be enabled.

   This is taking longer than it should, there might be connectivity
   issues.
   (BUTTON) Reload page

References

   1. https://enable-javascript.com/


--- SUCCESS ---
Stop the LXC container
Restore the previous snapshot.
Working time: 17 seconds.
Restore the previous snapshot.
Working time: 4 seconds.
Working time for this test: 5 minutes, 55 seconds.



Package linter:                  SUCCESS
Installation:                    SUCCESS
Deleting:                        SUCCESS
Installation in a sub path:      SUCCESS
Deleting from a sub path:        SUCCESS
Installation on the root:        SUCCESS
Deleting from root:              SUCCESS
Upgrade:                         SUCCESS
Installation in private mode:    SUCCESS
Installation in public mode:     SUCCESS
Multi-instance installations:    Not evaluated.
Malformed path:                  SUCCESS
Port already used:               SUCCESS
Backup:                          SUCCESS
Restore:                         SUCCESS
Change URL:                      SUCCESS
Level of this application: 7 (Successfully pass functional tests)
	   Level 1: 1
	   Level 2: 1
	   Level 3: 1
	   Level 4: 1
	   Level 5: 1
	   Level 6: 1
	   Level 7: 1
	   Level 8: 0
	   Level 9: 0
	   Level 10: 0
You can find the complete log of these tests in /home/CI_package_check/dev_CI/../package_check/Complete.log
Global working time for all tests: 1 hour, 23 minutes, 4 seconds.
Disable iptables rules.
Disable the network bridge.
The complete log for this application was duplicated and is accessible at /home/CI_package_check/dev_CI/../logs/_home_yunohost.app_ssh_chroot_directories_Rafi59_data_thelounge_ynh_PR11_complete.log

Sat Oct 26 19:59:05 UTC 2019
Test finished.
Finished: SUCCESS